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Accessing Campus Solutions 
In order to access Campus Solutions(PeopleSoft), you will need to follow the following steps 

 

Steps Descriptions 
1.  Access E-Services by going to www.uhcl.edu/eservices 

 
2.  Click on the Faculty and Staff tab.  Select the Campus Solutions Icon 

 
 

3.  Enter your 7 digit ID and password or you can also use your UHCL username and 
password.  Click on Sign In 

 
 

4.  You should now be signed in and begin navigating around the system. 
5.  

To log out of the system, click on  .  The system will display a dropdown to select Sign out. 

  

http://www.uhcl.edu/eservices
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Navigating through 9.2 Campus Solutions 
The following document will assist you in navigating through the new 9.2 Campus Solutions 

database.  
Steps Descriptions 
6.  Once you have logged into the database, you will be taken to the main Campus Solutions 

Administrator page.  

 
The tiles shown on this page are delivered by Oracle and have the most used items 
grouped together for each module.  You can view the items under each tile.   

7.  

To use your Favorites, click on the Navigator icon   that is on the upper right 
corner.  

8.  The side bar will appear with three options: Recent Places, My Favorites, Navigator 

 
  

9.  Recent Places:  This will show you the most recent pages you have accessed since you 
have signed in. 
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10.  My Favorites: This should be where any page you have designated as a favorite will 
appear 

 
11.  Navigator:  This is the location for traditional access to the navigations in the system that 

you have access to. 
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12.  When navigating through the system, at any point that you would like to return to the 

main list of navigations, you can click on the      button  that will be at the top 
level of your menu options 
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Adding Tiles to My Homepage 
You can personalize your Homepage to assist you with navigating and accessing your most 

frequently used pages.  
Steps Descriptions 
13.  Once you have logged into the database, you will be taken to the main Campus Solutions 

Administrator page.  

 
 

14.  

Once you navigate to a page within the system, click on the  icon and select Add 
to Homepage 

 
15.  You can either add it to the Campus Solutions Administrator Homepage (the default 

when you log in) or you can add it to My Homepage.  Click Add after you select your 
option 
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16.  

Click on the  button to return to the main page 
  

17.  On the top of your page, click on the down arrow to select My Homepage if you just 
added your tile to My Homepage 

 
18.  The page you just added will appear for you to utilize 

 
 

19.  If you determine that you no longer need a tile on your Homepage, you can click on the 

 icon again and select Personalize Homepage 
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20.  You can delete any tiles from here by click on the red “x” and then clicking Save 

 
21.  

Anytime you need to go back to the main page, you can use the Home button  to 
return you back to the Campus Solutions Administrator page.  
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Using Search 
After navigating through the menus to your desired procedure, the appropriate search 
page displays.  This is the final step before you can view the actual record in Campus 
Solutions.  Using the search helps you find the exact record you are looking for. 

Advanced and Basic Search Methods 
There are two types of search pages: the advanced search page and the basic search 
page.  When you select a page to navigate to, the system will often display the advanced 
search page, such as the Course Catalog page shown below.  The advanced search page 
generally offers several fields by which you may search for your record.  It allows you to 
narrow down your search by entering in more than one type of criteria.  The Course 
Catalog advanced search page below contains nine fields to assist in searching for the 
correct record. 

 
  

The Advanced search page offers a basic search option.  It will appear as a link next to the 
search action buttons.  In general, a basic search page offers just one or two fields by 
which you may perform your search and not a very efficient way to search for records. 
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The Search Mode that 
you can SWITCH TO. 

Use Prompts to help 
you fill in fields. 
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Search Criteria 
You can enter a full value or a partial value for any search field, including wildcards.  
Based on what you enter in the dialog box, the system uses the search record to present 
you with a list of possible matches or, if there is only one match, the page you requested. 

A search record is the list of defined search keys that help you locate data.  These are the 
fields you are prompted for on a search page.  Every transaction page or component 
listed in the menu columns has a search record associated with it.  If you select other 
pages that have a common search record, such as pages within a component or an 
associated link, you will not be prompted to enter search criteria again.  You'll be 
prompted for new search keys only when you select a new page outside of the 
component with a different search record. 

Field-Level Prompts and Validation   
Some edit box fields are linked to database prompt tables, which store values for shared 
information.  They're called prompt tables because you can prompt the system to give 
you a list of values from which you can select the correct value.  In many cases, fields are 
defined so that the system edits or validates the values you enter against a prompt table 
and ensures that the values are valid. 

Fields prompting against this kind of prompt table appear as edit boxes on your screen 
with a prompt button to the right.  When you click the prompt button  (or select 
[Alt]+5), a Lookup page opens, allowing you to search for the value you need.  For 
example, to look a term when accessing Student Grades, you can click on the lookup to 
view the list of options. 
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The Lookup Term page then opens.  

                        
 

A Search Results list displays on your lookup page.  When you find the term you need, 
click the link in the Term or Description columns and the system automatically will place 
the term in the Term field  
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Wildcard Searches 
You can use three different wildcard features to assist in searching for data.  These 
wildcards can be helpful in finding the exact information you want to process.  The 
following are the supported standard wildcard features: 

Wildcard Function 

% (percent sign) Match one or more characters. 

_ (underscore) Match any single character. 

\ (back slash) Escape character—don't treat the next character as a wildcard. 

 

Page Actions       
You'll notice that many search pages, both the advanced and the basic, contain the 
Include History and Correct History check boxes as page action options.  These options 
are included on effective dated records.  You can select what type of action you want to 
perform for your record before retrieving that record by selecting the appropriate check 
box.  Or, if you are unsure, you may leave the check boxes clear.  You will again have an 
opportunity to select the page action once you open the page you are searching for. 

Page Actions Function 

Include History Accesses all rows of an existing effective dated record.   
History, Current, and Future rows will be displayed in chronological 
order. 

Correct History Accesses all rows of an existing effective-dated record.   
Current and historical rows can be modified using this page action. 

Note:  This option is based on your security. 

 

 

Search Page Buttons 
The following search related buttons are located on Search Pages: 

Button Function 
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Processes the search once you have entered search criteria in the key 
fields above the Search button. 

 
Clears entered text from all fields on the page (without saving) so you 
can enter new criteria. 
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Search Results 
There are two possible results after running a search: 

1. You go directly to the desired record if your search criteria exactly matched a specific 
record. 

2. A Search Results List displays at the bottom of the search page with records that 
match your search criteria.  To access a specific record, click any of the underlined 
links in the Search Results grid row for that record. 

Note.  The Search Results for the advanced search will contain a link for each column 
entry, while the Basic search page results will only display the first column as a 
link. 
 

Note: The search function can retrieve up to 300 entries from the database. 
Use your browser's scroll bar to view all listings on the current page.  If the list 
is subdivided, click the right-pointing arrow above the grid to view the next set 
of listings. 

 
 

Tip:  If your search retrieves more than the maximum 300 listings, you should 
then attempt to narrow your search in another way if you are not able to 
retrieve the data you need on your first attempt. 
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Using Page Actions to View Data 
The page action buttons are located at the bottom right of each page on which they are 
applicable.  A grayed out button indicates the page is currently in that mode. 

The types of actions you can perform on rows of data depend on the data row type.  
When you retrieve, modify, or insert rows in a table, the Update/Display, Include History, 
and Correct History actions apply specific rules based on the effective date.  The action 
type that you select will dictate whether you can access certain fields and what you can 
do with each type of row. 

Action Button View Change Insert New Rows 

 
Update/Display 

Current, Future Future only Effective date greater than or equal 
to current row. 

 
Include History 

History, 
Current, Future 

Future only Effective date greater than or equal 
to current row. 

 
Correction 

History, 
Current, Future 

All existing 
rows 

No effective date restrictions. 

Note:  Sometimes these actions appear as check boxes on the search page. 

 

Effective Dates 
Effective-dating logic enables UHCL to maintain accurate historical information.  Effective 
dating allows storage of historical data, viewing of changes in data over time, and entry 
of future data.  For example, you may want to track several events in the career of a 
student, such as when they applied, was accepted, and graduated.  By inserting rows of 
data based on the student’s ID, you can build their history.  (See “Add a Row” section for 
how-to steps.) 

When you enter new information that is related to existing data, you don't want to lose 
or overwrite the data already stored in the database.  To retain history, you add a data 
row identified by the date when the information goes into effect: the Effective 
Date.  You can use the information to look at what's happened in the past and plan for 
the future.  UHCL categorizes effective-dated rows into the following basic types: 

Effective Dating Description 

Current The data row with the date closest to—but not greater than—the 
system date.   

Note: Only one row can be the current row. 
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History Data rows that have effective dates earlier than the current data 
row. 

Future Data rows that have effective dates later than the system date. 
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Identifying Parts of Campus Solutions 
It will also be helpful if you familiarize yourself with the types of page elements you will 
encounter on pages and how they work. We use many different types of elements to 
organize information on pages and to enable you to enter data. 

Navigation Bar 
The navigation bar in Campus Solutions offers you the opportunity to navigate several 
different ways as well as link back to your Home menu and a Sign Out button. 

 
 

Button Description 

Home   
Takes you back to your Home menu, the first menu 
column. 

Help Connects you to a context sensitive help item in 
PeopleBooks if possible.   Available on certain pages 

 
 

Toolbar Buttons 
At the bottom of most pages you'll find the toolbar, which changes depending on the 
type of page you are in.  The toolbar may include search list navigation buttons, page 
navigation buttons, and page action buttons.  The toolbar changes depending on the 
type of page that's active; therefore not all buttons shown below will display on every 
page.  Likewise, some buttons may be grayed out, indicating that that action is not 
available to you at that time. 

 

Button Name Description 

 
Save Sends the information you've entered on the page to the 

database.  You'll generally save when you come to the 
end of a component.  The Save command always updates 
the data for all pages in a group.  Upon save, the system 
briefly displays the "Saved" message in the upper right 
corner of the page. 

 Return to Search 
Page 

Returns you to the search page. 
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Button Name Description 

 
Next In List Displays the data for the next data row in your search 

results grid.  This button appears gray if you didn't select 
the data row from a search results grid, if there was only 
one row in the grid, or if the data displayed is the last row 
in the grid. 

 Previous in List Displays the data for the previous data row in your search 
results grid.  This button appears gray if you didn't select 
the data row from the search results grid, if there was 
only one row in the grid, or if the data displayed is the 
first row in the grid. 

 Update/Display Accesses existing rows of data on the database.  If data is 
effective-dated, displays only current and future rows. 

 Include History Displays all rows of data: current, future, and history. 

 Correction Accesses existing rows of data in the database and 
displays all effective-dated rows. Allows you to update all 
rows, including history rows.  This access is limited.  

 
Refresh page Forces the page displayed to reload, thereby validating 

that the most current information is displayed. 
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Working with Components and Pages 
Components consist of several pages within the same window that pertain to a specific 
task.  Usually these are related pages and need to be completed together.  Components 
contain page tabs with each tab containing a related page.  As you finish with one page, 
click the page tab of the next page to open it.  You can think of this as leafing through 
several pages of a single form: if you have to enter more information than fits on a single 
page, you simply move to the next page to complete the process.  Components are 
accessed from the navigation menu.   

A Page is the individual display and data-entry screen for each part of Campus Solutions.  
Pages are the primary way for you to view and alter the student data.  You'll use pages to 
view, enter, and update data.  Each page display also provides features in the form of 
buttons or links to help you navigate through the system.   

Page Tabs identify the page you are viewing and allow you to navigate through a 
component.  The white page tab indicates that page that is being displayed. 

 

 
 

Move Between Pages 
To move between pages, simply click on the tab of the page you wish to use.  In addition 
to clicking page tabs, you can also click the page links at the bottom of each page in the 
component to move to the next page.   

Note:  All pages in a group have the same search record so the prompt in the 
initial search dialog box is the same regardless of which page you access 
first—and you won't be prompted to enter new search criteria as you move 
from page to page in the component. 

Pages 

Component 

Page Tabs 

Page Links 



  Campus Solutions Basics 
  3/14/2017 

University of Houston, Clear Lake & PeopleSoft  Page 20 
Working with Components and Pages 

Save Component Data Entry 
Pages in a component are treated as a single entity when you try to save data.  When you 

click , data on all the pages is committed to the database.  You may be 
prompted at this time to enter data in required fields, if the system has not prompted 
you to do so already. 

If you click to leave a page before you save your data, the system will prompt you to save 
your data with the following message: 

 
If you want to save your data, click Yes on the above message and then [SAVE] your work. 
If you do NOT want to save your data, click No. 

Components with Related Links 
Occasionally you will see pages that, in addition to having links to other pages in the 
component, have links to related components or pages.  You may click any one of these 
links to access that page or component for the record you currently have open.  This 
convenience allows you to move easily to related transactions to enter or view data 
without going through the search process again.  

When you click a component link, you'll notice that the new transaction contains the 
same component links, enabling you to return to the original transaction if desired.  The 
component or page in which you are working appears in black text and is not underlined.  
Some components may identify these related links in another way.  For example, you 
might see the button [Go] along with the related links at the bottom of a page.  You may 
also see a drop-down list box with the word “…More,” containing several more related 
transaction links. 

When you have finished making changes in your component you will be prompted to 
save if necessary. 

Related Link Samples: 
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Opening a New Window 
At the top of all Pages you will notice the New Window link.  Clicking this link will open a 
new browser window, or child window, showing the menu navigation to your current 
position.  From this point you can open a new transaction to view or enter new data.   

Tips for Using New Window 
There are certain rules of thumb to keep in mind when using the New Window feature: 

• Before opening a new window, save any changes made in the current window.  If the 
session times out while you are working in a new window, you may lose any unsaved 
changes. 

• After a certain length of inactivity in one of your child windows (30 minutes), your new 
window session will timeout or expire.  This does not invalidate your other, current 
window but simply means this expired window is no longer useable.  Any unsaved 
changes will be lost.  
 

 
 



  Campus Solutions Basics 
  3/14/2017 

University of Houston, Clear Lake & PeopleSoft  Page 22 
Identifying Types of Data Entry Fields 

Identifying Types of Data Entry Fields 
On pages, you'll see several types of data-entry fields, each designed to offer different 
ways to enter and maintain information.  The different kinds of data-entry fields serve a 
common purpose—to provide you with a simple way to enter and update data in your 
tables.  You'll type data directly into some fields, such as edit boxes and long edit boxes.  
Other data-entry fields (such as radio buttons and drop-down list boxes) present you 
with a list of choices.  Understanding how to use each type of data-entry element will 
help you use the system more efficiently. 

Types of Data-Entry Fields 
Data-entry elements, which are always associated with specific database fields, include 
the following: 

Field Type Description 

Check Box 

 or  

Small, square box that enables or disables an option.  Typically, you 

select the check box by clicking within it ; this adds a check 
mark and the option becomes enabled.  Click it again to clear the 

check box  and the option is disabled.  The spacebar can also 
be used to check and uncheck. 

Drop-Down List Box  

 

Rectangular box similar to an edit box with a down arrow prompt 
button within the box.  Clicking the prompt button expands the 
box to display a list of valid values from which you can select a 
single option.  Typing the first character of a value will jump you to 
an item that starts with that character; Press again to jump to the 
next value in the list. 

Edit Box 

 

Rectangular box into which you enter data.  The size of the edit 
box—the number of characters you can enter—is determined by 
the length of the database field.  Edit boxes for fields with prompt 
tables have a magnifying glass prompt button to the right.  

Grid Entry fields arranged like a spreadsheet with a navigation bar or 

footer and  (Add) and/or  (Delete) buttons for each row. 

Long Edit Box 

 

Long rectangular box into which you enter long free form text 
items such as comments. 

Radio Button 

 or  

Small round button that represents one option in a group of 
mutually exclusive options.  Only one radio button in a group can 
be selected at one time (by clicking it).  The spacebar can also be 
used to select and unselect. 
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Required Fields * 
 

An *asterisk in front of a data-entry field on a page indicates a required field.  A required 
field means you must enter data into that field if you want to continue on to the next 
field or to save the page.  In some cases, you may not be informed of a required field 
until you attempt to save or leave the page.  

 If you save the page before entering data, the field will turn red and an error message 
dialog will display on your page.  Click [OK] on the error message and enter the correct 
data in that field.  Required fields are often drop-down lists or are accompanied by a 
prompt button to assist you in entering the correct data.  Make use of these prompts to 
help you find the correct data. 

 

Examples of Required Fields (note the * before each field): 
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Data Navigation 

Tab Between Fields 
To move among the data-entry fields on a page, press the [Tab] key or click once on the 
field.  The [Tab] key moves you one field at a time in a sequence determined in the page 
definition.  To get to the next field press the [Tab] key again.  [Shift]+[Tab] moves you 
back a field rather than forward. 

Grids & Scroll Areas 
On some pages, you may want some of the fields to repeat so that you can enter multiple 
rows or occurrences of data.  For this purpose, we use grids and scroll areas on a page.  
Grids and scroll areas give you the ability to add, edit, and view multiple occurrences of 
data for a group of fields on one page.  Each time you add a new row, you are actually 
adding a new row of data to the database. 

Grid controls resemble and behave like an embedded spreadsheet with column headings, 
rows, and cells.  The cells are generally equivalent to regular edit boxes and allow you to 
enter data as if you were in a spreadsheet program.  Or, you might see a grid that 
contains a drop-down list box, check box, image, link, or button, in addition to edit boxes.  
Also, the cells may sometimes contain display-only information. 

When you add a new row, it is placed below the row in which you are clicking Add button 

.  
 

Tabbed Grids 
 

 
Tabbed grids provide a means of viewing multiple columns of information without having 
to scroll to the right to view them.  By clicking the tabs, you can view the remaining 

columns of data for your grid.  Alternatively, some grids may have a view next button  
to the right of the tabs that enables you to view the remaining pages in that component.   

Scroll Areas 
 
A scroll area behaves like a grid, in that each occurrence represents one row of data in 
the database.  You'll notice, however, that within a scroll area the fields are randomly 
arranged rather than setup like a spreadsheet. 
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A scroll area looks like a group box with navigation tools in the navigation header.  It 
does not actually contain a scroll bar that you would use to scroll up and down 
between the various rows.  Instead, you use the buttons and links in the area’s header 
to help you "scroll" through the data rows (e.g. View All, First, Last, Next, Previous). 

 

 
 
 
Data Grid Navigation                                                  

 
Grids and scroll areas contain the same type of navigation structure.  Instead of a 
traditional scroll bar to scroll through the rows of data, we use navigation buttons and 
links.  The table below shows the action options and their function.  You will find these 
buttons or links in the navigation header, within the row itself, or to the right of the tabs 
in a tabbed grid as appropriate.  

Button or Link Function 

 or   
Inserts a new row. 

   Deletes the current row of data. 

 In tabbed grid only, expands grid columns to the right so tabs 
are no longer needed. 

 In tabbed grid only, expanded grid is returned to tabbed state. 

 Enables you to find a specific row of data. 

 Displays all rows of data on a page. When this feature is enabled, 
the link changes to read View 1 so that you can return to the 
original setting. 

 Takes you to the first row of data. 

 Displays the previous row. 

 Displays the next row of data. 
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 Takes you to the last row of data. 

Reference the ‘Using Keyboard Shortcuts’ section to find keyboard shortcuts that you can 
use for some of the above buttons and links. 
 

Keyboard Shortcuts 
Working in an Internet browser-based environment can often be very mouse intensive.  
There are many keyboard navigation alternatives to using the mouse in the browser.  We 
call these Keyboard Shortcuts.   

Keyboard Shortcut keys perform an immediate action.  When you press any of the key 
combinations below, the designated action occurs. 

 

Note: You'll notice that several hot keys perform different functions depending on the 
page you are in, such as a transaction page or a search page.   

 

Shortcut 
Key 

Button or Link Action 

[Alt]+5  
 

Opens lookup page. 
Opens the calendar prompt. 

[Alt]+7 

 

Inserts one or more rows in a grid or scroll area. 

[Alt]+8 
 

Deletes row in a grid or scroll area. 

[Alt]+ . 
 

Next in grid, scroll, or search page results list. 

[Alt]+ , 
 

Previous in grid, scroll area, or search page results list. 

 

Shortcut Access Keys 
Access keys move the focus of your cursor to a particular push button on your page.  

Pressing [Enter] executes the command—the equivalent of clicking the button with your 

normal select mouse button.  
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The table below outlines the shortcuts you may use in place of clicking the equivalent 
action button with your mouse.  After pressing the desired key combination from the 
list below, you must then press the [Enter] key to execute the action.  For example, 
to save a page you would press Alt+1.  

Note: Some access keys have multiple actions assigned to them, and their usage 
depends on the currently active page. 

Shortcut 
Access 
Key 

Button or Link Action 

[Alt]+1 
 

Save page in a transaction. 

[Alt]+2 
 

Return to search page from transaction page. 

[Alt]+3 
 

View next row in list when button is active. 

[Alt]+4 
 

View previous row in list when button is active. 

 

Move between Page Tabs 
There are three options to move between page tabs within a component:  

1. Click on the tab of the page you wish to view. 

2. Click the page links at the bottom of each page in the component to move to another 
page. 

3. Press the corresponding page tab access keys.  Press [Alt] and the underlined 
character on the tab you want to switch to and then press [Enter].  (e.g. [Alt]+[A] and 
then [Enter]) 



  Campus Solutions Basics 
  3/14/2017 

University of Houston, Clear Lake & PeopleSoft  Page 28 
Data Navigation 

 



  Campus Solutions Basics 
  3/14/2017 

University of Houston, Clear Lake & PeopleSoft  Page 29 
Adding and Deleting Rows 

Adding and Deleting Rows 

Add a Row 
When entering data, it is necessary to add rows to input additional information into the 
system.  Adding rows allows you to include more information in one record, such as 
recording additional service indicators.  Adding rows is also useful because it allows you 
to build a historical record of events. 

Using rows of data allows you to add additional sets of information to a record without 
having to overwrite the original information entered.  Rows can have dates associated 
with them; however, dates are not always required.  Dated rows are used whenever it is 
necessary to keep historical records of all the information entered into the system. 

To add a new row entry: 

Step Action 

1.  
Click the Add button  in the area you want to add a new row. 

2.  Enter the needed information. 

3.  Click . 
 

 

! Warning !:  If you forget to insert a new row, any data you enter will overwrite the 
existing data in that row.  The system does not prompt you to insert a row; 
it assumes that you want to type over existing information.  However, the 
changes you make will not take effect until you save the page.  If you exit 
the page without saving, the data you accidentally typed over will remain 
intact. 
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Delete a Row 

You can delete rows of data by clicking the button.  By deleting a row you are 
permanently deleting this line item from the record. 

Note:  In many areas on campus, it is important NOT to ever delete rows of data.  The 
history is very important to keep.  Verify that deleting a row is acceptable in your 
process. 

 

To delete a row: 

Step Action 

1.  Select the row you want to delete by clicking a field in the row you want to delete. 

2.  
Click the Delete button  

3.  Click [OK]. 

4.  Click . 
 

Tip:  If you have not saved the information yet, you can retrieve the row just deleted by 
clicking the Back button in your browser or close the transaction without saving 
your changes.  Any other changes you made to the page will not be saved. 

 

My Favorites 

You can create a Favorites list within the system to allow you to easy access pages that 
are used frequently, to add a favorite: 

Step Action 

1.  Navigate to the page you are wanting to add to your list of favorites 

2.  
Click on the “hamburger” icon   

3.  Click on Add To Favorites from the list of options. 

4.  The system will show a dialog box and allow you to change the description if you 
need  
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5.  Click OK. 

6.  The page will appear on your My Favorites list 
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Browser Settings and Printing Guidelines 
Windows Operating Systems Mac Operating Systems 

o Disable Pop-up Blockers o Disable Pop-up Blockers 
Internet Explorer Settings 

o Clear Browser Cache 
Click Tools>Internet Options>General 
Tab 
Under Browsing History, click Delete 
Deselect the Preserve Favorites website 
data checkbox 
Click Delete>OK 

o Under Advanced tab, scroll to Security 
header and deselect Do Not save 
encrypted pages to disk 

Note: If Pop-up blockers are enabled add 
my.uh.edu to the Exceptions/Allowed Sites 

Click Tools>Internet Options>Privacy 
Tab>Settings button. Click Close>OK 
 

Internet Explorer Printing 
(use when Print button/link does not appear) 

1. From the Edit Menu, click Select All 
2. From the File Menu, click Print Preview 
3. Change As laid out on screen option to 

As Selected on screen 
4. Change Shrink to fit to 100% 
5. Click Print icon. 

 
Mozilla Firefox Settings 

o Clear Browser Cache 
Click Tools>Clear Recent History 
Under Time range to clear, select 
Everything  
Select the Cookies and Cache 
checkboxes 
Click Clear Now 

Note: If Pop-up blockers are enabled add 
my.uh.edu to the Exceptions 

Click Tools>Options>Content 
Tab>Exceptions button. Click OK 
 

Mozilla Firefox Printing 
(use when Print button/link does not appear) 

Safari Settings 
o Clear Browser Cache 

Click Safari>Empty Cache>Empty 
 

Safari Printing 
(use when Print button/link does not appear) 

1. In order for the entire form to print, click 
on the form to activate it. 

2. From the File Menu, click Print. 
3. Change Scale % from 100 to 150 
4. Change Safari to Paper Handling 
5. From Pages to Print, Select Odd Only 
6. Click Print. 

 
Mozilla Firefox Settings 

o Clear Browser Cache 
Click Tools>Clear Recent History 
Under Time range to clear, select 
Everything  
Select the Cookies and Cache checkboxes 
Click Clear Now 

Note: If Pop-up blockers are enabled add 
my.uh.edu to the Exceptions 

Click Tools>Options>Content Tab>Exceptions 
button. Click OK 
 

Mozilla Firefox Printing 
(use when Print button/link does not appear) 

5. From the Edit Menu, click Select All 
6. From the File Menu, click Print 
7. Under Print range, click the Selection radio 

button 
8. Click OK 

 
 
The following browsers are supported for 
PeopleSoft (E-Services, PASS, Finance and HR and 
Campus Solutions) 

• Chrome 50 and up   
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1. From the Edit Menu, click Select All 
2. From the File Menu, click Print 
3. Under Print range, click the Selection 

radio button 
4. Click OK 

• Internet Explorer 11 and up 

• Microsoft Edge 21 and up 

• Mozilla Firefox 52 and up (ESR version only) 

• Mac OS 9 and up 
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